summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-19 02:24:09 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-19 02:24:09 +0000
commit8f1dff8d62661fe3121bb1b69576f33a15556288 (patch)
tree9dee0ecf099afb2f9ed4f531c633b89542530a2c /app-emulation
parentVersion bump; remove old. This version closes bug #209667 (disabled ucd-snmp ... (diff)
downloadgentoo-2-8f1dff8d62661fe3121bb1b69576f33a15556288.tar.gz
gentoo-2-8f1dff8d62661fe3121bb1b69576f33a15556288.tar.bz2
gentoo-2-8f1dff8d62661fe3121bb1b69576f33a15556288.zip
Fix USE=osmesa build failure with mesa-8.1_rc1_pre20120814 (bug #431832).
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/files/wine-1.5.11-osmesa-check.patch (renamed from app-emulation/wine/files/wine-1.5.10-osmesa-check.patch)17
-rw-r--r--app-emulation/wine/wine-1.5.10.ebuild4
-rw-r--r--app-emulation/wine/wine-1.5.11.ebuild4
-rw-r--r--app-emulation/wine/wine-9999.ebuild4
5 files changed, 23 insertions, 13 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 09f9c96180cb..fead059aea02 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.425 2012/08/18 00:03:20 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.426 2012/08/19 02:24:09 tetromino Exp $
+
+ 19 Aug 2012; Alexandre Rostovtsev <tetromino@gentoo.org> wine-1.5.10.ebuild,
+ -files/wine-1.5.10-osmesa-check.patch, wine-1.5.11.ebuild,
+ +files/wine-1.5.11-osmesa-check.patch, wine-9999.ebuild:
+ Fix USE=osmesa build failure with mesa-8.1_rc1_pre20120814 (bug #431832).
*wine-1.5.11 (18 Aug 2012)
diff --git a/app-emulation/wine/files/wine-1.5.10-osmesa-check.patch b/app-emulation/wine/files/wine-1.5.11-osmesa-check.patch
index 86d90ca5bc4c..2bd7694ab699 100644
--- a/app-emulation/wine/files/wine-1.5.10-osmesa-check.patch
+++ b/app-emulation/wine/files/wine-1.5.11-osmesa-check.patch
@@ -1,4 +1,4 @@
-From a233e35ca650db2758de0fd31450b8ce2d86d5e3 Mon Sep 17 00:00:00 2001
+From 22fcf835dfe713ad93f649a901973208e0f7b62d Mon Sep 17 00:00:00 2001
From: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Tue, 7 Aug 2012 01:29:01 -0400
Subject: [PATCH] Do not check for libGL symbols when checking libOSMesa
@@ -8,22 +8,27 @@ libOSMesa without explicitly linking to libGL. In addition, in
mesa-8.0.x and earlier, libOSMesa needs to be explicitly linked to
libglapi if mesa was built with shared glapi, see
https://bugs.gentoo.org/show_bug.cgi?id=399813
+And in mesa-8.1.x, libOSMesa in addition needs libdl, libpthread, and
+libstdc++, see https://bugs.gentoo.org/show_bug.cgi?id=431832
---
- configure.ac | 5 ++++-
- 1 files changed, 4 insertions(+), 1 deletions(-)
+ configure.ac | 8 +++++++-
+ 1 files changed, 7 insertions(+), 1 deletions(-)
diff --git a/configure.ac b/configure.ac
-index 4bd43d1..c7a718f 100644
+index 15ada86..6eab75e 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1132,7 +1132,10 @@ This probably prevents linking to OpenGL. Try deleting the file and restarting c
+@@ -1133,7 +1133,13 @@ This probably prevents linking to OpenGL. Try deleting the file and restarting c
if test "$ac_cv_header_GL_osmesa_h" = "yes"
then
- WINE_CHECK_SONAME(OSMesa,glAccum,,,[$X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
+ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[$X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
+ if test "x$ac_cv_lib_soname_OSMesa" = "x"; then
-+ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[-lglapi $X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
++ osmesa_save_CC=$CC
++ CC=$CXX
++ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[-lglapi -lpthread -ldl $X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
++ CC=$osmesa_save_CC
+ fi
fi
WINE_NOTICE_WITH(osmesa,[test "x$ac_cv_lib_soname_OSMesa" = "x"],
diff --git a/app-emulation/wine/wine-1.5.10.ebuild b/app-emulation/wine/wine-1.5.10.ebuild
index ac1d5ec9512e..93567a5c5cdd 100644
--- a/app-emulation/wine/wine-1.5.10.ebuild
+++ b/app-emulation/wine/wine-1.5.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.10.ebuild,v 1.2 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.10.ebuild,v 1.3 2012/08/19 02:24:09 tetromino Exp $
EAPI="4"
@@ -131,7 +131,7 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
- epatch "${FILESDIR}"/${PN}-1.5.10-osmesa-check.patch #429386
+ epatch "${FILESDIR}"/${PN}-1.5.11-osmesa-check.patch #429386
epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
eautoreconf
diff --git a/app-emulation/wine/wine-1.5.11.ebuild b/app-emulation/wine/wine-1.5.11.ebuild
index 3f47938c9d3c..42ff29dcb3cf 100644
--- a/app-emulation/wine/wine-1.5.11.ebuild
+++ b/app-emulation/wine/wine-1.5.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.11.ebuild,v 1.1 2012/08/18 00:03:20 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.11.ebuild,v 1.2 2012/08/19 02:24:09 tetromino Exp $
EAPI="4"
@@ -131,7 +131,7 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
- epatch "${FILESDIR}"/${PN}-1.5.10-osmesa-check.patch #429386
+ epatch "${FILESDIR}"/${PN}-1.5.11-osmesa-check.patch #429386
epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
eautoreconf
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 2e11bf2ae0a7..07a6a82541d4 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.112 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.113 2012/08/19 02:24:09 tetromino Exp $
EAPI="4"
@@ -131,7 +131,7 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
- epatch "${FILESDIR}"/${PN}-1.5.10-osmesa-check.patch #429386
+ epatch "${FILESDIR}"/${PN}-1.5.11-osmesa-check.patch #429386
epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
eautoreconf