summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-03-28 06:50:41 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-03-28 06:50:41 +0000
commit8b54ecd687dc283bc39887facc766e55efc67187 (patch)
treebd10d72183ac497bc5dff7b9284a8d86f3b56206 /app-emulation/xmame
parentadded libjpeg as a compile-time dependency. (diff)
downloadgentoo-2-8b54ecd687dc283bc39887facc766e55efc67187.tar.gz
gentoo-2-8b54ecd687dc283bc39887facc766e55efc67187.tar.bz2
gentoo-2-8b54ecd687dc283bc39887facc766e55efc67187.zip
version upgrade
Diffstat (limited to 'app-emulation/xmame')
-rw-r--r--app-emulation/xmame/ChangeLog13
-rw-r--r--app-emulation/xmame/files/digest-xmame-0.59.11
-rw-r--r--app-emulation/xmame/xmame-0.59.1.ebuild57
3 files changed, 68 insertions, 3 deletions
diff --git a/app-emulation/xmame/ChangeLog b/app-emulation/xmame/ChangeLog
index fe497b303030..4aec5d3b9efd 100644
--- a/app-emulation/xmame/ChangeLog
+++ b/app-emulation/xmame/ChangeLog
@@ -1,14 +1,21 @@
# ChangeLog for app-games/xmame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/ChangeLog,v 1.1 2002/02/04 06:21:53 tod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/ChangeLog,v 1.2 2002/03/28 06:50:41 gbevin Exp $
-*xmame-0.56.1 ((3 Feb 2002)
+*xmame-0.59.1 (28 Mar 2002)
+
+ 28 Mar 2002; Geert Bevin <gbevin@gentoo.org> xmame-0.59.1.ebuild
+ files/digest-xmame-0.59.1 :
+
+ Version upgrade
+
+*xmame-0.56.1 (3 Feb 2002)
3 Feb 2002; T.Neidt <tneidt@gentoo.org> ChangeLog :
Moved to app-emulation/xmame with the other emulators (Bug 421)
-*xmame-0.55.2 ((3 Feb 2002)
+*xmame-0.55.2 (3 Feb 2002)
3 Feb 2002; T.Neidt <tneidt@gentoo.org> ChangeLog :
diff --git a/app-emulation/xmame/files/digest-xmame-0.59.1 b/app-emulation/xmame/files/digest-xmame-0.59.1
new file mode 100644
index 000000000000..21b1957f5ace
--- /dev/null
+++ b/app-emulation/xmame/files/digest-xmame-0.59.1
@@ -0,0 +1 @@
+MD5 5b46b6edac55d8a4db8dc46ff56d035b xmame-0.59.1.tar.bz2 5472519
diff --git a/app-emulation/xmame/xmame-0.59.1.ebuild b/app-emulation/xmame/xmame-0.59.1.ebuild
new file mode 100644
index 000000000000..8e4c35130860
--- /dev/null
+++ b/app-emulation/xmame/xmame-0.59.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <blutgens@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/xmame-0.59.1.ebuild,v 1.1 2002/03/28 06:50:41 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Multiple Arcade Machine Emulator for X11"
+SRC_URI="http://x.mame.net/download/${P}.tar.bz2"
+HOMEPAGE="http://x.mame.net"
+
+DEPEND="virtual/x11
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ >=sys-libs/zlib-1.1.3-r2"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s:CFLAGS = -O -Wall:\#CFLAGS=:g" -e \
+ "s:PREFIX = /usr/local:PREFIX = /usr:g" -e \
+ "s:MANDIR = \$\(PREFIX\)/man/man6:MANDIR = \$\(PREFIX\)/share/man/man6:g" \
+ makefile.unix > makefile.unix.tmp
+ mv makefile.unix.tmp makefile.unix
+
+ if [ "`use sdl`" ]; then
+ sed -e "s:DISPLAY_METHOD = x11:DISPLAY_METHOD = SDL:g" \
+ makefile.unix > makefile.unix.tmp
+ mv makefile.unix.tmp makefile.unix
+ fi
+
+ if [ "`use esd`" ]; then
+ sed -e "s/\# SOUND_ESOUND/SOUND_ESOUND/g" makefile.unix > Makefile
+ else
+ mv makefile.unix Makefile
+ fi
+}
+
+src_compile() {
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+
+ make PREFIX=${D}/usr install
+
+# dodoc gzips
+ dodoc doc/{changes.*,dga2.txt,gamelist.mame,readme.mame,xmamerc.dist}
+ dodoc doc/{xmame-doc.ps,xmame-doc.txt}
+# Don't really want html files gzipped
+ insinto /usr/share/doc/${P}/html
+ doins doc/*.html
+
+ dosym xmame.SDL /usr/bin/xmame
+
+}
+