summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-06 04:12:07 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-06 04:12:07 +0000
commit91d78b14f249a27cf4dea3e93e96300fb9c9203c (patch)
tree1033700291acb00b4d76ada5ad85def41b830b9e /app-emulation/softgun
parentkeep .maildir (Manifest recommit) (diff)
downloadgentoo-2-91d78b14f249a27cf4dea3e93e96300fb9c9203c.tar.gz
gentoo-2-91d78b14f249a27cf4dea3e93e96300fb9c9203c.tar.bz2
gentoo-2-91d78b14f249a27cf4dea3e93e96300fb9c9203c.zip
initial ebuild #71484
Diffstat (limited to 'app-emulation/softgun')
-rw-r--r--app-emulation/softgun/ChangeLog8
-rw-r--r--app-emulation/softgun/Manifest2
-rw-r--r--app-emulation/softgun/files/digest-softgun-0.071
-rw-r--r--app-emulation/softgun/metadata.xml6
-rw-r--r--app-emulation/softgun/softgun-0.07.ebuild40
5 files changed, 57 insertions, 0 deletions
diff --git a/app-emulation/softgun/ChangeLog b/app-emulation/softgun/ChangeLog
new file mode 100644
index 000000000000..cb8488b127ec
--- /dev/null
+++ b/app-emulation/softgun/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/softgun
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/ChangeLog,v 1.1 2004/12/06 04:12:07 vapier Exp $
+
+*softgun-0.07 (05 Dec 2004)
+
+ 05 Dec 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Yuri Vasilevski #71484.
diff --git a/app-emulation/softgun/Manifest b/app-emulation/softgun/Manifest
new file mode 100644
index 000000000000..3c3cda530e1e
--- /dev/null
+++ b/app-emulation/softgun/Manifest
@@ -0,0 +1,2 @@
+MD5 755f71dfb567dcf2f6f382b7d08b87e5 softgun-0.07.ebuild 1011
+MD5 ad6c326f2a31bc17f529c4d0fa6296a1 files/digest-softgun-0.07 61
diff --git a/app-emulation/softgun/files/digest-softgun-0.07 b/app-emulation/softgun/files/digest-softgun-0.07
new file mode 100644
index 000000000000..1ca97b232284
--- /dev/null
+++ b/app-emulation/softgun/files/digest-softgun-0.07
@@ -0,0 +1 @@
+MD5 6c8a08d7e6cc1dee3b65c1d8a79cd3c2 softgun-0.07.tgz 129171
diff --git a/app-emulation/softgun/metadata.xml b/app-emulation/softgun/metadata.xml
new file mode 100644
index 000000000000..1ac8ccd0e973
--- /dev/null
+++ b/app-emulation/softgun/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>arm</herd>
+<maintainer>
+</pkgmetadata>
diff --git a/app-emulation/softgun/softgun-0.07.ebuild b/app-emulation/softgun/softgun-0.07.ebuild
new file mode 100644
index 000000000000..2e4e0b7f2b83
--- /dev/null
+++ b/app-emulation/softgun/softgun-0.07.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/softgun-0.07.ebuild,v 1.1 2004/12/06 04:12:07 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="ARM software emulator"
+HOMEPAGE="http://softgun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e 's:/usr/local:$(DESTDIR)/usr:' \
+ Makefile || die "sed Makefile failed"
+ sed -i \
+ -e "/^CFLAGS/s:-O9.*-fomit-frame-pointer:${CFLAGS}:" \
+ config.mk || die "sed config.mk failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "Make feiled"
+}
+
+src_install() {
+ dodir /usr/bin
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc README defaultconfig
+}
+
+pkg_postinst() {
+ einfo "To create a configuration file, run as user:"
+ einfo " gzcat /usr/share/doc/${PF}/defaultconfig.gz > ~/.emuconfig"
+}