summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2008-01-27 10:01:17 +0000
committerLuca Barbato <lu_zero@gentoo.org>2008-01-27 10:01:17 +0000
commite34842f37d52c33980c6155dd314d1e0bf8319bd (patch)
tree81c68be2c90876d2e17fb6670ab22a528dc9a1e7 /app-emulation/qemu-user
parentInitial import, thanks to Jouni Rinne <jouni.rinne@pp1.inet.fi>, bug #137019 (diff)
downloadgentoo-2-e34842f37d52c33980c6155dd314d1e0bf8319bd.tar.gz
gentoo-2-e34842f37d52c33980c6155dd314d1e0bf8319bd.tar.bz2
gentoo-2-e34842f37d52c33980c6155dd314d1e0bf8319bd.zip
Version bump
(Portage version: 2.1.4)
Diffstat (limited to 'app-emulation/qemu-user')
-rw-r--r--app-emulation/qemu-user/ChangeLog9
-rw-r--r--app-emulation/qemu-user/files/digest-qemu-user-0.9.13
-rw-r--r--app-emulation/qemu-user/qemu-user-0.9.1.ebuild95
3 files changed, 105 insertions, 2 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index a532cc87efac..863ffd40e9b4 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-user
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.30 2007/07/02 14:02:43 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.31 2008/01/27 10:01:16 lu_zero Exp $
+
+*qemu-user-0.9.1 (27 Jan 2008)
+
+ 27 Jan 2008; Luca Barbato <lu_zero@gentoo.org> +qemu-user-0.9.1.ebuild:
+ Version bump
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> qemu-user-0.8.0.ebuild,
qemu-user-0.8.0.20060329.ebuild, qemu-user-0.8.1.ebuild,
diff --git a/app-emulation/qemu-user/files/digest-qemu-user-0.9.1 b/app-emulation/qemu-user/files/digest-qemu-user-0.9.1
new file mode 100644
index 000000000000..8e50cf7424be
--- /dev/null
+++ b/app-emulation/qemu-user/files/digest-qemu-user-0.9.1
@@ -0,0 +1,3 @@
+MD5 6591df8e9270eb358c881de4ebea1262 qemu-0.9.1.tar.gz 2804104
+RMD160 ee7bdb55a4540df2082d4bde9ebfd2f4e6f201a5 qemu-0.9.1.tar.gz 2804104
+SHA256 4756d0b4a4dc7dd88354bc6b37d381e4462dd328d0feef94803e90c0455835a5 qemu-0.9.1.tar.gz 2804104
diff --git a/app-emulation/qemu-user/qemu-user-0.9.1.ebuild b/app-emulation/qemu-user/qemu-user-0.9.1.ebuild
new file mode 100644
index 000000000000..815e0c6c760c
--- /dev/null
+++ b/app-emulation/qemu-user/qemu-user-0.9.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.9.1.ebuild,v 1.1 2008/01/27 10:01:16 lu_zero Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="http://fabrice.bellard.free.fr/qemu/${P/-user/}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="" #qvm86 debug nptl qemu-fast nptlonly"
+RESTRICT="strip test"
+
+DEPEND="virtual/libc
+ app-text/texi2html
+ !<=app-emulation/qemu-0.7.0"
+RDEPEND=""
+
+S="${WORKDIR}/${P/-user/}"
+
+QA_TEXTRELS="usr/bin/qemu-armeb
+ usr/bin/qemu-i386
+ usr/bin/qemu-mips
+ usr/bin/qemu-arm
+ usr/bin/qemu-ppc"
+
+#set_target_list() {
+# TARGET_LIST="i386-user ppc-user mips-user"
+# arm broken
+# TARGET_LIST="arm-user armeb-user i386-user ppc-user mips-user"
+# export TARGET_LIST
+#}
+
+#pkg_setup() {
+# if [ "$(gcc-major-version)" == "4" ]; then
+# die "Qemu must build with GCC 3"
+# fi
+#}
+
+#RUNTIME_PATH="/emul/gnemul/"
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/qemu-0.7.0-ppc-linker.patch"
+
+ # Alter target makefiles to accept CFLAGS set via flag-o.
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
+ # Ensure mprotect restrictions are relaxed for emulator binaries
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # Prevent install of kernel module by qemu's makefile
+ sed -i 's/\(.\/install.sh\)/#\1/' Makefile
+ # avoid strip
+ sed -i 's:$(INSTALL) -m 755 -s:$(INSTALL) -m 755:' Makefile Makefile.target
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ myconf="--disable-gcc-check"
+# set_target_list
+# --interp-prefix=${RUNTIME_PATH}/qemu-%M
+ ./configure \
+ --prefix=/usr \
+ --enable-slirp \
+ --kernel-path=${KV_DIR} \
+ --enable-linux-user \
+ --disable-system \
+ ${myconf} \
+ || die "could not configure"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install \
+ prefix="${D}/usr" \
+ bindir="${D}/usr/bin" \
+ datadir="${D}/usr/share/qemu" \
+ docdir="${D}/usr/share/doc/${P}" \
+ mandir="${D}/usr/share/man" || die
+
+ rm -fR "${D}/usr/share/{man,qemu}"
+ rm -fR "${D}/usr/bin/qemu-img"
+}