summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2009-03-07 14:31:12 +0000
committerLuca Barbato <lu_zero@gentoo.org>2009-03-07 14:31:12 +0000
commita31ca2708c7c42e1bd9c97ed8b14f79c1c9d581c (patch)
tree3a924d73d56fb64b52f650fd3ac1d918af6ae4de /app-emulation/qemu-user
parentTransition to eapi 2 use deps (diff)
downloadgentoo-2-a31ca2708c7c42e1bd9c97ed8b14f79c1c9d581c.tar.gz
gentoo-2-a31ca2708c7c42e1bd9c97ed8b14f79c1c9d581c.tar.bz2
gentoo-2-a31ca2708c7c42e1bd9c97ed8b14f79c1c9d581c.zip
New version
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/qemu-user')
-rw-r--r--app-emulation/qemu-user/ChangeLog9
-rw-r--r--app-emulation/qemu-user/qemu-user-0.10.0.ebuild90
2 files changed, 97 insertions, 2 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index 7c128188cad7..b78ce8970ba9 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-user
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.32 2008/02/01 20:24:13 lu_zero Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.33 2009/03/07 14:31:12 lu_zero Exp $
+
+*qemu-user-0.10.0 (07 Mar 2009)
+
+ 07 Mar 2009; Luca Barbato <lu_zero@gentoo.org> +qemu-user-0.10.0.ebuild:
+ New version
01 Feb 2008; Luca Barbato <lu_zero@gentoo.org>
-files/qemu-user-0.7.0-errno.patch, -files/qemu-0.8.0-gcc4-hacks.patch,
diff --git a/app-emulation/qemu-user/qemu-user-0.10.0.ebuild b/app-emulation/qemu-user/qemu-user-0.10.0.ebuild
new file mode 100644
index 000000000000..2eecc64c23db
--- /dev/null
+++ b/app-emulation/qemu-user/qemu-user-0.10.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.10.0.ebuild,v 1.1 2009/03/07 14:31:12 lu_zero Exp $
+
+inherit eutils flag-o-matic
+
+MY_PN=${PN/-user/}
+MY_P=${P/-user/}
+
+SRC_URI="http://savannah.nongnu.org/download/${MY_PN}/${MY_P}.tar.gz"
+
+DESCRIPTION="Open source dynamic translator"
+HOMEPAGE="http://bellard.org/qemu/index.html"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+IUSE=""
+RESTRICT="strip test binchecks"
+
+DEPEND="app-text/texi2html
+ !<=app-emulation/qemu-0.7.0"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ # prevent docs to get automatically installed
+ sed -i '/$(DESTDIR)$(docdir)/d' Makefile
+ # Alter target makefiles to accept CFLAGS set via flag-o
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # avoid strip
+ sed -i 's/$(INSTALL) -m 755 -s/$(INSTALL) -m 755/' Makefile
+}
+
+src_compile() {
+ local mycc conf_opts
+
+ conf_opts="--enable-linux-user"
+ conf_opts="${conf_opts} --disable-darwin-user --disable-bsd-user"
+ conf_opts="${conf_opts} --disable-system"
+ conf_opts="${conf_opts} --disable-vnc-tls"
+ conf_opts="$conf_opts --disable-curses"
+ conf_opts="$conf_opts --disable-gfx-check --disable-sdl"
+ conf_opts="$conf_opts --disable-vde"
+ conf_opts="$conf_opts --disable-kqemu"
+# use fdt || conf_opts="--disable-fdt"
+
+ conf_opts="$conf_opts --prefix=/usr --disable-bluez --disable-kvm"
+
+ ./configure ${conf_opts} || die "econf failed"
+
+ mycc=$(cat qemu/config-host.mak | egrep "^CC=" | cut -d "=" -f 2)
+
+ filter-flags -fpie -fstack-protector
+
+ # If using gentoo's compiler set the SPEC to non-hardened
+ if [ ! -z ${GCC_SPECS} -a -f ${GCC_SPECS} ]; then
+ local myccver=$(${mycc} -dumpversion)
+ local gccver=$($(tc-getBUILD_CC) -dumpversion)
+
+ #Is this a SPEC for the right compiler version?
+ myspec="${GCC_SPECS/${gccver}/${myccver}}"
+ if [ "${myspec}" == "${GCC_SPECS}" ]; then
+ shopt -s extglob
+ GCC_SPECS="${GCC_SPECS/%hardened*specs/vanilla.specs}"
+ shopt -u extglob
+ else
+ unset GCC_SPECS
+ fi
+ fi
+
+ emake || die "emake qemu failed"
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ rm -fR "${D}/usr/share"
+ dohtml qemu-doc.html
+ dohtml qemu-tech.html
+}
+