summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-09-15 11:47:19 +0000
committerPacho Ramos <pacho@gentoo.org>2010-09-15 11:47:19 +0000
commit23b7dc870199636385f81804271bf67a236a343d (patch)
tree6a1a6ed52d7a83dbf8aa328a9cf8dcf1da472b34 /app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20100915-r99.ebuild
parentVersion bump, remove old. (diff)
downloadgentoo-2-23b7dc870199636385f81804271bf67a236a343d.tar.gz
gentoo-2-23b7dc870199636385f81804271bf67a236a343d.tar.bz2
gentoo-2-23b7dc870199636385f81804271bf67a236a343d.zip
Version bump, remove old.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20100915-r99.ebuild')
-rw-r--r--app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20100915-r99.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20100915-r99.ebuild b/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20100915-r99.ebuild
new file mode 100644
index 000000000000..3b4f985172c3
--- /dev/null
+++ b/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20100915-r99.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20100915-r99.ebuild,v 1.1 2010/09/15 11:47:19 pacho Exp $
+
+inherit emul-linux-x86
+
+LICENSE="LGPL-2 MIT"
+
+SRC_URI="mirror://gentoo/${PN}-${PV}-r99.tar.bz2"
+
+KEYWORDS="-* ~amd64 ~amd64-linux"
+IUSE=""
+
+DEPEND="app-admin/eselect-opengl"
+RDEPEND=">=app-emulation/emul-linux-x86-xlibs-20100611
+ !<app-emulation/emul-linux-x86-xlibs-20100611
+ media-libs/mesa"
+
+src_unpack() {
+ emul-linux-x86_src_unpack
+ rm -f "${S}/usr/lib32/libGL.so" || die
+}
+
+pkg_postinst() {
+ #update GL symlinks
+ eselect opengl set --use-old
+}