summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-11-30 18:48:20 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-11-30 18:48:20 +0000
commitb9ed2470eac75ae1a7fa11c83fc0ad1288b31d99 (patch)
treee84e1bad9e6594f2ad01bb850ade08440074a472 /app-editors
parentFix building on Prefix platforms, bug #385621 (diff)
downloadgentoo-2-b9ed2470eac75ae1a7fa11c83fc0ad1288b31d99.tar.gz
gentoo-2-b9ed2470eac75ae1a7fa11c83fc0ad1288b31d99.tar.bz2
gentoo-2-b9ed2470eac75ae1a7fa11c83fc0ad1288b31d99.zip
Version bump to 3.0.1, update to EAPI 4, see bug #380061 and bug #392485.
(Portage version: 2.1.10.38/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/ChangeLog8
-rw-r--r--app-editors/scite/files/scite-3.0.1-no-lua.patch16
-rw-r--r--app-editors/scite/scite-3.0.1.ebuild82
3 files changed, 105 insertions, 1 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index 3798d01f21c1..57a7115a504a 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/scite
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.121 2011/08/13 15:55:04 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.122 2011/11/30 18:48:20 nelchael Exp $
+
+*scite-3.0.1 (30 Nov 2011)
+
+ 30 Nov 2011; Krzysztof Pawlik <nelchael@gentoo.org> +scite-3.0.1.ebuild,
+ +files/scite-3.0.1-no-lua.patch:
+ Version bump to 3.0.1, update to EAPI 4, see bug #380061 and bug #392485.
*scite-2.28 (13 Aug 2011)
diff --git a/app-editors/scite/files/scite-3.0.1-no-lua.patch b/app-editors/scite/files/scite-3.0.1-no-lua.patch
new file mode 100644
index 000000000000..d63416a81eb7
--- /dev/null
+++ b/app-editors/scite/files/scite-3.0.1-no-lua.patch
@@ -0,0 +1,16 @@
+diff -Nru 3.0.1.vanilla/scite/src/SciTEProps.cxx 3.0.1/scite/src/SciTEProps.cxx
+--- 3.0.1.vanilla/scite/src/SciTEProps.cxx 2011-11-30 19:39:41.059801342 +0100
++++ 3.0.1/scite/src/SciTEProps.cxx 2011-11-30 19:39:53.211835004 +0100
+@@ -1702,10 +1702,12 @@
+
+ // return the int value of the command name passed in.
+ int SciTEBase::GetMenuCommandAsInt(SString commandName) {
++#ifndef NO_LUA
+ int i = IFaceTable::FindConstant(commandName.c_str());
+ if (i != -1) {
+ return IFaceTable::constants[i].value;
+ }
++#endif
+ // Otherwise we might have entered a number as command to access a "SCI_" command
+ return commandName.value();
+ }
diff --git a/app-editors/scite/scite-3.0.1.ebuild b/app-editors/scite/scite-3.0.1.ebuild
new file mode 100644
index 000000000000..f4794d7bfbaa
--- /dev/null
+++ b/app-editors/scite/scite-3.0.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-3.0.1.ebuild,v 1.1 2011/11/30 18:48:20 nelchael Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://www.scintilla.org/SciTE.html"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="lua"
+
+RDEPEND="x11-libs/gtk+:2
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}/gtk"
+
+src_prepare() {
+ cd "${WORKDIR}/scintilla/gtk"
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+
+ cd "${WORKDIR}/scite/gtk"
+ sed -i makefile \
+ -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
+ || die "error patching makefile"
+
+ cd "${S}"
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${PN}-3.0.1-no-lua.patch"
+}
+
+src_compile() {
+ emake -C ../../scintilla/gtk
+ if use lua; then
+ emake
+ else
+ emake NO_LUA=1
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ emake prefix="${D}/usr" install
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv "${D}/usr/bin/SciTE" "${D}/usr/bin/scite" || die
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ rm -f "${D}/usr/share/applications/SciTE.desktop"
+ insinto /usr/share/applications
+ doins "${FILESDIR}/scite.desktop"
+
+ doman ../doc/scite.1
+ dodoc ../README
+}