summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-04-05 20:43:35 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-04-05 20:43:35 +0000
commit09d8e74398014878369eeaf7eb715ac50fb4dc4a (patch)
tree1f3a142fda01c89f70c896336a5aa2e7bdc84280 /app-editors
parentVersion bump (diff)
downloadgentoo-2-09d8e74398014878369eeaf7eb715ac50fb4dc4a.tar.gz
gentoo-2-09d8e74398014878369eeaf7eb715ac50fb4dc4a.tar.bz2
gentoo-2-09d8e74398014878369eeaf7eb715ac50fb4dc4a.zip
EAPI 5 bump wrt bug 543906.
Signed-off-by: monsieurp@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 93491BB8)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jext/ChangeLog11
-rw-r--r--app-editors/jext/jext-5.0-r1.ebuild60
-rw-r--r--app-editors/jext/jext-5.0.ebuild4
3 files changed, 70 insertions, 5 deletions
diff --git a/app-editors/jext/ChangeLog b/app-editors/jext/ChangeLog
index 6c4f424502be..11d0af725014 100644
--- a/app-editors/jext/ChangeLog
+++ b/app-editors/jext/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/jext
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/ChangeLog,v 1.21 2011/01/17 02:26:17 fordfrog Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/ChangeLog,v 1.22 2015/04/05 20:43:35 monsieurp Exp $
+
+*jext-5.0-r1 (05 Apr 2015)
+
+ 05 Apr 2015; Patrice Clement <monsieurp@gentoo.org> +jext-5.0-r1.ebuild,
+ jext-5.0.ebuild:
+ EAPI 5 bump wrt bug 543906.
17 Jan 2011; Miroslav Šulc <fordfrog@gentoo.org> -files/jext-gentoo.sh:
Removed unused file, bug #340571 (thanks to jalan <jalanpalmer@gmail.com>)
@@ -72,4 +78,3 @@
29 Apr 2003; Todd Berman <tberman@gentoo.org> jext-3.2_pre3.ebuild:
Initial Import.
-
diff --git a/app-editors/jext/jext-5.0-r1.ebuild b/app-editors/jext/jext-5.0-r1.ebuild
new file mode 100644
index 000000000000..7b56b0de9d9a
--- /dev/null
+++ b/app-editors/jext/jext-5.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/jext-5.0-r1.ebuild,v 1.1 2015/04/05 20:43:35 monsieurp Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A cool and fully featured editor in Java"
+HOMEPAGE="http://www.jext.org/"
+MY_PV="${PV/_}"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-sources-${MY_PV}.tar.gz"
+LICENSE="|| ( GPL-2 JPython )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/jython:0
+ dev-java/jgoodies-looks:1.2
+ dev-java/gnu-regexp:1"
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${PN}-src-${MY_PV}"
+
+java_prepare() {
+ rm -v "${S}"/extplugins/Admin/*.jar || die
+ # bundles some com.microstar.xml who knows what's that
+ # also com.jgoodies.uif_lite which is apparently some jgoodies-looks
+ # example code which we don't package and there is probably no point
+ rm -rf src/lib/gnu || die
+}
+
+src_compile() {
+ cd "${S}/src" || die
+ eant jar $(use_doc javadocs) \
+ -Dclasspath="$(java-pkg_getjars jython,jgoodies-looks-1.2,gnu-regexp-1)"
+}
+
+src_install () {
+ java-pkg_newjar lib/${P}.jar
+ java-pkg_dojar lib/dawn*.jar
+
+ java-pkg_dolauncher ${PN} \
+ --main org.jext.Jext \
+ --java_args '-Dpython.path=$(java-config --classpath=jython)' \
+ -pre "${FILESDIR}/${PN}-pre"
+
+ if use doc; then
+ java-pkg_dohtml -A .css .gif .jpg -r docs/api
+ fi
+}
+
+pkg_postinst() {
+ elog "Plugins are currently not built/installed. Patches welcome."
+}
diff --git a/app-editors/jext/jext-5.0.ebuild b/app-editors/jext/jext-5.0.ebuild
index db62c52ddbcc..c864027e1d41 100644
--- a/app-editors/jext/jext-5.0.ebuild
+++ b/app-editors/jext/jext-5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/jext-5.0.ebuild,v 1.2 2009/06/12 16:03:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/jext-5.0.ebuild,v 1.3 2015/04/05 20:43:35 monsieurp Exp $
EAPI=2