summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-04-01 15:38:03 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-04-01 15:38:03 +0000
commitad3c08f42cf123187375d2dd526515ad9be831df (patch)
treedf7671e923f21b34789687b19f6ff68796cb941d /app-editors/lfhex
parentfix bug #191665, in selinux portion of configure script. (diff)
downloadgentoo-2-ad3c08f42cf123187375d2dd526515ad9be831df.tar.gz
gentoo-2-ad3c08f42cf123187375d2dd526515ad9be831df.tar.bz2
gentoo-2-ad3c08f42cf123187375d2dd526515ad9be831df.zip
patch to work with NDEBUG thanks to Guenther Brunthaler bug #205269. QA improvements thanks to Jakub. removed old versions
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-editors/lfhex')
-rw-r--r--app-editors/lfhex/ChangeLog11
-rw-r--r--app-editors/lfhex/files/ndebug.patch23
-rw-r--r--app-editors/lfhex/lfhex-0.3.7-r1.ebuild35
-rw-r--r--app-editors/lfhex/lfhex-0.3.7.1.ebuild28
-rw-r--r--app-editors/lfhex/lfhex-0.4-r1.ebuild37
5 files changed, 69 insertions, 65 deletions
diff --git a/app-editors/lfhex/ChangeLog b/app-editors/lfhex/ChangeLog
index e2f846c30a74..9bd6662109ae 100644
--- a/app-editors/lfhex/ChangeLog
+++ b/app-editors/lfhex/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/lfhex
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/ChangeLog,v 1.19 2007/07/22 08:56:15 omp Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/ChangeLog,v 1.20 2008/04/01 15:38:03 dragonheart Exp $
+
+*lfhex-0.4-r1 (01 Apr 2008)
+
+ 01 Apr 2008; Daniel Black <dragonheart@gentoo.org> +files/ndebug.patch,
+ -lfhex-0.3.7-r1.ebuild, -lfhex-0.3.7.1.ebuild, +lfhex-0.4-r1.ebuild:
+ patch to work with NDEBUG thanks to Guenther Brunthaler bug #205269. QA
+ improvements thanks to Jakub. removed old versions
22 Jul 2007; David Shakaryan <omp@gentoo.org> lfhex-0.3.7-r1.ebuild,
lfhex-0.3.7.1.ebuild, lfhex-0.3.7.2.ebuild, lfhex-0.4.ebuild:
diff --git a/app-editors/lfhex/files/ndebug.patch b/app-editors/lfhex/files/ndebug.patch
new file mode 100644
index 000000000000..e2f76607f32a
--- /dev/null
+++ b/app-editors/lfhex/files/ndebug.patch
@@ -0,0 +1,23 @@
+Patches lfhex to compile fine with -DNDEBUG (which is typically used to
+compile release versions without debugging information).
+
+The original version made an essential function call within an assert()
+statement - but defining NDEBUG makes any assert statements into no-ops.
+
+Patch written 2008 by Guenther Brunthaler <gb_about_gnu@gmx.net>
+Index: src/reader.cpp
+===================================================================
+--- src.orig/reader.cpp
++++ src/reader.cpp
+@@ -278,7 +278,11 @@ uchar Reader::operator[] (off_t offset)
+ "attempt to access past end of file");
+
+ off_t page_idx = offset/_pageSize;
++ #ifdef NDEBUG
++ (void)loadPage( page_idx );
++ #else
+ assert( loadPage( page_idx ) );
++ #endif
+ return _data[page_idx][ offset%_pageSize ];
+ }
+
diff --git a/app-editors/lfhex/lfhex-0.3.7-r1.ebuild b/app-editors/lfhex/lfhex-0.3.7-r1.ebuild
deleted file mode 100644
index 7feb6e184ffc..000000000000
--- a/app-editors/lfhex/lfhex-0.3.7-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.3.7-r1.ebuild,v 1.10 2007/07/22 08:56:15 omp Exp $
-
-inherit eutils
-
-DESCRIPTION="A fast, efficient hex-editor with support for large files and comparing binary files"
-HOMEPAGE="http://freshmeat.net/projects/lfhex"
-SRC_URI="http://home.earthlink.net/~eyekode/data/${P}.tar.gz"
-LICENSE="QPL-1.0"
-SLOT="0"
-KEYWORDS="x86 ppc amd64"
-
-IUSE=""
-
-RDEPEND="=x11-libs/qt-3*
- >=x11-libs/libXt-1.0.0"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- sys-devel/bison
- sys-apps/grep
- sys-apps/net-tools"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/lfhex-gcc3-inline-fix.patch
-}
-
-src_install() {
- dobin bin/lfhex
- dodoc README
- dodoc README.install
-}
diff --git a/app-editors/lfhex/lfhex-0.3.7.1.ebuild b/app-editors/lfhex/lfhex-0.3.7.1.ebuild
deleted file mode 100644
index d838a09a8a96..000000000000
--- a/app-editors/lfhex/lfhex-0.3.7.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.3.7.1.ebuild,v 1.3 2007/07/22 08:56:15 omp Exp $
-
-inherit eutils
-
-DESCRIPTION="A fast, efficient hex-editor with support for large files and comparing binary files"
-HOMEPAGE="http://freshmeat.net/projects/lfhex"
-SRC_URI="http://home.earthlink.net/~eyekode/data/${P}.tar.gz"
-LICENSE="QPL-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-IUSE=""
-
-RDEPEND="=x11-libs/qt-3*
- >=x11-libs/libXt-1.0.0"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- sys-devel/bison
- sys-apps/grep
- sys-apps/net-tools"
-
-src_install() {
- dobin bin/lfhex
- dodoc README
-}
diff --git a/app-editors/lfhex/lfhex-0.4-r1.ebuild b/app-editors/lfhex/lfhex-0.4-r1.ebuild
new file mode 100644
index 000000000000..449b9b9e6c87
--- /dev/null
+++ b/app-editors/lfhex/lfhex-0.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.4-r1.ebuild,v 1.1 2008/04/01 15:38:03 dragonheart Exp $
+
+inherit qt4 toolchain-funcs
+
+DESCRIPTION="A fast, efficient hex-editor with support for large files and comparing binary files"
+HOMEPAGE="http://stoopidsimple.com/lfhex"
+SRC_URI="http://stoopidsimple.com/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+RDEPEND="$(qt4_min_version 4)
+ >=x11-libs/libXt-1.0.0"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/ndebug.patch
+}
+src_compile() {
+# eqmake4 lfhex.pro
+ eqmake4 || die "eqmake4 failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin lfhex
+ dodoc README
+}