summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-12-24 02:18:10 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-12-24 02:18:10 +0000
commitfbefc11f77fc2c26100a07cebb0a751809584dd3 (patch)
tree81169dfe409c9b64574eb2c7e3b80d597d6b853a /app-doc
parentRemoved support for portaudio 18 since it is no longer in the tree. (diff)
downloadgentoo-2-fbefc11f77fc2c26100a07cebb0a751809584dd3.tar.gz
gentoo-2-fbefc11f77fc2c26100a07cebb0a751809584dd3.tar.bz2
gentoo-2-fbefc11f77fc2c26100a07cebb0a751809584dd3.zip
Updated with patch for bug #251533 (relpath empty string replacement
issue). (Portage version: 2.2_rc17/cvs/Linux 2.6.27.7 x86_64)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/ChangeLog6
-rw-r--r--app-doc/doxygen/doxygen-1.5.7.1.ebuild3
-rw-r--r--app-doc/doxygen/files/doxygen-1.5.7.1-substitute.patch24
3 files changed, 31 insertions, 2 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index 8ff0c1fbada4..6e6c7a250392 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-doc/doxygen
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.154 2008/11/04 09:49:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.155 2008/12/24 02:18:09 nerdboy Exp $
+
+ 24 Dec 2008; Steve Arnold <nerdboy@gentoo.org>
+ +files/doxygen-1.5.7.1-substitute.patch, doxygen-1.5.7.1.ebuild:
+ Updated with patch for bug #251533 (relpath empty string replacement issue).
04 Nov 2008; Diego Pettenò <flameeyes@gentoo.org> doxygen-1.5.7.1.ebuild:
Add flex dependency.
diff --git a/app-doc/doxygen/doxygen-1.5.7.1.ebuild b/app-doc/doxygen/doxygen-1.5.7.1.ebuild
index 941cc09b5427..bfbd9d7bffc2 100644
--- a/app-doc/doxygen/doxygen-1.5.7.1.ebuild
+++ b/app-doc/doxygen/doxygen-1.5.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.7.1.ebuild,v 1.2 2008/11/04 09:49:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.7.1.ebuild,v 1.3 2008/12/24 02:18:09 nerdboy Exp $
EAPI=1
@@ -57,6 +57,7 @@ src_unpack() {
# Consolidate patches, apply FreeBSD configure patch, codepage patch,
# qtools stuff, and patches for bugs 129142, 121770, and 129560.
epatch "${FILESDIR}/${PN}-1.5-legacy-patches.diff"
+ epatch "${FILESDIR}/${P}-substitute.patch"
# remove internal libpng - see bug #210237
epatch "${FILESDIR}/${PN}-1.5-system-libpng.patch"
diff --git a/app-doc/doxygen/files/doxygen-1.5.7.1-substitute.patch b/app-doc/doxygen/files/doxygen-1.5.7.1-substitute.patch
new file mode 100644
index 000000000000..7d87d4a880d2
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.5.7.1-substitute.patch
@@ -0,0 +1,24 @@
+--- doxygen-1.5.7.1-orig/src/util.cpp 2008-10-04 14:28:00.000000000 +0200
++++ doxygen-1.5.7.1/src/util.cpp 2008-12-18 20:55:15.000000000 +0100
+@@ -4447,10 +4447,10 @@
+
+ QCString substitute(const char *s,const char *src,const char *dst)
+ {
+- if (s==0 || src==0 || dst==0) return s;
++ if (s==0 || src==0) return s;
+ const char *p, *q;
+ int srcLen = strlen(src);
+- int dstLen = strlen(dst);
++ int dstLen = dst ? strlen(dst) : 0;
+ int resLen;
+ if (srcLen!=dstLen)
+ {
+@@ -4469,7 +4469,7 @@
+ int l = (int)(q-p);
+ memcpy(r,p,l);
+ r+=l;
+- memcpy(r,dst,dstLen);
++ if (dst) memcpy(r,dst,dstLen);
+ r+=dstLen;
+ }
+ strcpy(r,p);