summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2012-11-08 03:15:48 +0000
committerDane Smith <c1pher@gentoo.org>2012-11-08 03:15:48 +0000
commit23ebe66db51be6362829a54c267f9d6192932427 (patch)
tree486c46f2c479280049803d5a05ad1fe5cb28c709 /app-crypt/md6sum
parentDrop gnuconfig_update #160173 by Diego Elio Pettenò. (diff)
downloadgentoo-2-23ebe66db51be6362829a54c267f9d6192932427.tar.gz
gentoo-2-23ebe66db51be6362829a54c267f9d6192932427.tar.bz2
gentoo-2-23ebe66db51be6362829a54c267f9d6192932427.zip
Revision bump. Add patch to fix CFLAGS respect wrt bug 442066. Drop old.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key E27104B3)
Diffstat (limited to 'app-crypt/md6sum')
-rw-r--r--app-crypt/md6sum/ChangeLog8
-rw-r--r--app-crypt/md6sum/files/md6sum-1.0-cflags.patch27
-rw-r--r--app-crypt/md6sum/md6sum-1.0-r1.ebuild (renamed from app-crypt/md6sum/md6sum-1.0.ebuild)3
3 files changed, 36 insertions, 2 deletions
diff --git a/app-crypt/md6sum/ChangeLog b/app-crypt/md6sum/ChangeLog
index bddff1f4b538..aac3ebebe0ff 100644
--- a/app-crypt/md6sum/ChangeLog
+++ b/app-crypt/md6sum/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/md6sum
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/md6sum/ChangeLog,v 1.2 2012/11/05 23:38:30 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/md6sum/ChangeLog,v 1.3 2012/11/08 03:15:48 c1pher Exp $
+
+*md6sum-1.0-r1 (08 Nov 2012)
+
+ 08 Nov 2012; Dane Smith <c1pher@gentoo.org> -md6sum-1.0.ebuild,
+ +md6sum-1.0-r1.ebuild, +files/md6sum-1.0-cflags.patch:
+ Revision bump. Add patch to fix CFLAGS respect wrt bug 442066. Drop old.
05 Nov 2012; Dane Smith <c1pher@gentoo.org> md6sum-1.0.ebuild, metadata.xml:
Drop hwoarang as maintainer and leave in crypto herd at his request.
diff --git a/app-crypt/md6sum/files/md6sum-1.0-cflags.patch b/app-crypt/md6sum/files/md6sum-1.0-cflags.patch
new file mode 100644
index 000000000000..18e1937c4424
--- /dev/null
+++ b/app-crypt/md6sum/files/md6sum-1.0-cflags.patch
@@ -0,0 +1,27 @@
+--- Makefile.in 2012-11-07 22:04:51.207982344 -0500
++++ Makefile.in.new 2012-11-07 22:06:00.905977580 -0500
+@@ -18,19 +18,19 @@
+ all: md6sum
+
+ md6sum: $(OBJS)
+- $(CC) $(OBJS) $(CXXFLAGS) $(LDFLAGS) -o $@
++ $(CC) $(OBJS) $(CFLAGS) $(LDFLAGS) -o $@
+
+ md6_compress.o: md6_compress.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ md6_mode.o: md6_mode.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ md6_nist.o: md6_nist.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ md6sum.o: md6sum.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ clean:
+ rm *.o
diff --git a/app-crypt/md6sum/md6sum-1.0.ebuild b/app-crypt/md6sum/md6sum-1.0-r1.ebuild
index 53e991a4e6e2..f7f6fede525b 100644
--- a/app-crypt/md6sum/md6sum-1.0.ebuild
+++ b/app-crypt/md6sum/md6sum-1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/md6sum/md6sum-1.0.ebuild,v 1.2 2012/11/05 23:38:30 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/md6sum/md6sum-1.0-r1.ebuild,v 1.1 2012/11/08 03:15:48 c1pher Exp $
EAPI="4"
@@ -17,6 +17,7 @@ IUSE=""
src_prepare() {
epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}/${P}-cflags.patch"
}
src_install() {