summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-08 07:09:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-08 07:09:55 +0000
commit40f74d24cfb3fe3abe6fe37a2bdd66a1d7b202a5 (patch)
treefa259f43efa18355fdf010bb6acdd6ab12c89303 /app-arch/unshield
parentFix building against pthreads-win32 (bug #407371, thanks to Nathan Phillip Br... (diff)
downloadgentoo-2-40f74d24cfb3fe3abe6fe37a2bdd66a1d7b202a5.tar.gz
gentoo-2-40f74d24cfb3fe3abe6fe37a2bdd66a1d7b202a5.tar.bz2
gentoo-2-40f74d24cfb3fe3abe6fe37a2bdd66a1d7b202a5.zip
Upstream snapshot to include support for some IS installers wrt #361971 by Roberto Castagnola
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/unshield')
-rw-r--r--app-arch/unshield/ChangeLog11
-rw-r--r--app-arch/unshield/files/unshield-bootstrap.patch32
-rw-r--r--app-arch/unshield/unshield-0.6_p20120308.ebuild36
3 files changed, 77 insertions, 2 deletions
diff --git a/app-arch/unshield/ChangeLog b/app-arch/unshield/ChangeLog
index 53ad528e15aa..0398b8493b02 100644
--- a/app-arch/unshield/ChangeLog
+++ b/app-arch/unshield/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/unshield
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unshield/ChangeLog,v 1.19 2011/02/27 10:34:25 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unshield/ChangeLog,v 1.20 2012/03/08 07:09:55 ssuominen Exp $
+
+*unshield-0.6_p20120308 (08 Mar 2012)
+
+ 08 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +unshield-0.6_p20120308.ebuild, +files/unshield-bootstrap.patch:
+ Upstream snapshot to include support for some IS installers wrt #361971 by
+ Roberto Castagnola
27 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> unshield-0.6.ebuild:
USE="static-libs" and remove libunshield.la in favour of libunshield.pc.
diff --git a/app-arch/unshield/files/unshield-bootstrap.patch b/app-arch/unshield/files/unshield-bootstrap.patch
new file mode 100644
index 000000000000..565b9e520f5c
--- /dev/null
+++ b/app-arch/unshield/files/unshield-bootstrap.patch
@@ -0,0 +1,32 @@
+This is replaced by `AT_M4DIR=m4 eautoreconf` in the ebuild.
+
+--- bootstrap
++++ bootstrap
+@@ -26,17 +26,17 @@
+ INCLUDES="-I m4"
+ fi
+ set -x
+-aclocal $INCLUDES
+-autoheader
++# aclocal $INCLUDES
++# autoheader
+
+ # Check For OSX
+ # rhcp011235@gmail.com
+
+-KERNEL_NAME=`uname -s`
+-if [ "$KERNEL_NAME" = "Darwin" ]; then
+- glibtoolize --copy --automake
+-else
+- libtoolize --copy --automake
+-fi
+-automake --copy --foreign --add-missing
+-autoconf
++# KERNEL_NAME=`uname -s`
++# if [ "$KERNEL_NAME" = "Darwin" ]; then
++# glibtoolize --copy --automake
++# else
++# libtoolize --copy --automake
++# fi
++# automake --copy --foreign --add-missing
++# autoconf
diff --git a/app-arch/unshield/unshield-0.6_p20120308.ebuild b/app-arch/unshield/unshield-0.6_p20120308.ebuild
new file mode 100644
index 000000000000..8a1fe0ff53e7
--- /dev/null
+++ b/app-arch/unshield/unshield-0.6_p20120308.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unshield/unshield-0.6_p20120308.ebuild,v 1.1 2012/03/08 07:09:55 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="InstallShield CAB file extractor"
+HOMEPAGE="http://github.com/twogood/unshield http://sourceforge.net/projects/synce/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/openssl:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-bootstrap.patch
+ ./bootstrap
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}