summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-20 03:02:24 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-20 03:02:24 +0000
commitcdeaa4d5aee5305806871f498d58e6b9c26435f9 (patch)
tree4bdb19081c87a48359667313fa318d733bfe5fd6 /app-arch/bzip2
parentdont want to pass --libdir because it will just cause gcc to install into a l... (diff)
downloadgentoo-2-cdeaa4d5aee5305806871f498d58e6b9c26435f9.tar.gz
gentoo-2-cdeaa4d5aee5305806871f498d58e6b9c26435f9.tar.bz2
gentoo-2-cdeaa4d5aee5305806871f498d58e6b9c26435f9.zip
rework how we handle tests/cross-compiling
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-arch/bzip2')
-rw-r--r--app-arch/bzip2/bzip2-1.0.3-r5.ebuild13
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.3-no-test.patch9
2 files changed, 15 insertions, 7 deletions
diff --git a/app-arch/bzip2/bzip2-1.0.3-r5.ebuild b/app-arch/bzip2/bzip2-1.0.3-r5.ebuild
index b8a975231043..51f354d0a161 100644
--- a/app-arch/bzip2/bzip2-1.0.3-r5.ebuild
+++ b/app-arch/bzip2/bzip2-1.0.3-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.3-r5.ebuild,v 1.4 2005/08/19 19:21:17 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.3-r5.ebuild,v 1.5 2005/08/20 03:02:24 vapier Exp $
inherit eutils multilib toolchain-funcs flag-o-matic
@@ -24,6 +24,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-shared-largefile-support.patch
epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
epatch "${FILESDIR}"/${PN}-1.0.2-chmod.patch
+ epatch "${FILESDIR}"/${P}-no-test.patch
sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die "sed manpath"
# - Generate symlinks instead of hardlinks
@@ -32,12 +33,6 @@ src_unpack() {
-e 's:ln $(PREFIX)/bin/:ln -s :' \
-e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
Makefile || die "sed links"
-
- # bzip2 will to run itself after it has built itself which we
- # can't do if we are cross compiling. -solar
- if [[ -x /bin/bzip2 ]] && tc-is-cross-compiler ; then
- sed -i -e 's:./bzip2 -:bzip2 -:g' Makefile || die "sed cross-compile"
- fi
}
src_compile() {
@@ -51,6 +46,10 @@ src_compile() {
fi
use static && append-flags -static
emake ${makeopts} all || die "Make failed"
+
+ if ! tc-is-cross-compiler ; then
+ make check || die "test failed"
+ fi
}
src_install() {
diff --git a/app-arch/bzip2/files/bzip2-1.0.3-no-test.patch b/app-arch/bzip2/files/bzip2-1.0.3-no-test.patch
new file mode 100644
index 000000000000..672c89dfbd20
--- /dev/null
+++ b/app-arch/bzip2/files/bzip2-1.0.3-no-test.patch
@@ -0,0 +1,9 @@
+--- Makefile
++++ Makefile
+@@ -23,5 +23,5 @@
+ bzlib.o
+
+-all: libbz2.a bzip2 bzip2recover test
++all: libbz2.a bzip2 bzip2recover
+
+ bzip2: libbz2.a bzip2.o