summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-01-27 20:40:43 +0000
committerThilo Bangert <bangert@gentoo.org>2009-01-27 20:40:43 +0000
commitb4ccce7b9c46923470d4f02fe1be6325901ccf24 (patch)
treeabbaccc1bd3d14e8ba1508dcf7605bf876d06aae /app-admin/srlog2
parentversion bump (diff)
downloadgentoo-2-b4ccce7b9c46923470d4f02fe1be6325901ccf24.tar.gz
gentoo-2-b4ccce7b9c46923470d4f02fe1be6325901ccf24.tar.bz2
gentoo-2-b4ccce7b9c46923470d4f02fe1be6325901ccf24.zip
version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'app-admin/srlog2')
-rw-r--r--app-admin/srlog2/ChangeLog9
-rw-r--r--app-admin/srlog2/srlog2-0.85.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/app-admin/srlog2/ChangeLog b/app-admin/srlog2/ChangeLog
index b1c9bd0f549a..d3554d2e1bea 100644
--- a/app-admin/srlog2/ChangeLog
+++ b/app-admin/srlog2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/srlog2
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/srlog2/ChangeLog,v 1.2 2008/06/26 07:58:40 bangert Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/srlog2/ChangeLog,v 1.3 2009/01/27 20:40:43 bangert Exp $
+
+*srlog2-0.85 (27 Jan 2009)
+
+ 27 Jan 2009; Thilo Bangert <bangert@gentoo.org> +srlog2-0.85.ebuild:
+ version bump
26 Jun 2008; Thilo Bangert <bangert@gentoo.org> srlog2-0.80.ebuild:
remove bindnow-flags - as per bug #226939
diff --git a/app-admin/srlog2/srlog2-0.85.ebuild b/app-admin/srlog2/srlog2-0.85.ebuild
new file mode 100644
index 000000000000..0d95e5195dba
--- /dev/null
+++ b/app-admin/srlog2/srlog2-0.85.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/srlog2/srlog2-0.85.ebuild,v 1.1 2009/01/27 20:40:43 bangert Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Secure Remote Log transmission system"
+HOMEPAGE="http://untroubled.org/srlog2/"
+SRC_URI="http://untroubled.org/srlog2/archive/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-libs/bglibs-1.104
+ app-crypt/nistp224
+ >=dev-libs/libtomcrypt-1.03"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo -n "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo -n "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo -n "/usr/include/bglibs" > conf-bgincs
+ echo -n "/usr/lib/bglibs" > conf-bglibs
+ echo -n /usr/bin > conf-bin
+ echo -n /usr/share/man > conf-man
+
+ # Deliberatly don't fix curve25519 as its full of PIC unfriendly asm code
+ # uncomment and follow
+ # http://www.gentoo.org/proj/en/hardened/pic-fix-guide.xml (Thunk it in
+ # assembly) to fix curve25519/*.s
+
+ sed -i -e 's/x86cpuid /x86cpuid -fno-pie /' curve25519/curve25519.impl.do
+ sed -i -e 's/) >/) -fPIC >/g' curve25519/Makefile
+ #If this isn't fixed it just includes app-crypt/nistp224 support only
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install_prefix="${D}" install || die "emake install failed"
+ dodoc ANNOUNCEMENT NEWS README *.html
+}
+
+pkg_postinst() {
+ # even with the pic code fixed this only works on 32 bit cpus
+ #elog 'curve25519 only works on 32-bit x86 systems at the moment'
+ elog 'curve25519 support is currenly broken'
+}