summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-11-20 00:09:28 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-11-20 00:09:28 +0000
commitef1910f1f245d7034f9b5154fe0f37cb3be7bd61 (patch)
treea8a6f40aa4ddc46e7124c6b2c7d29d4c2322c8a9 /app-admin/conky
parentMarked ppc stable. (diff)
downloadgentoo-2-ef1910f1f245d7034f9b5154fe0f37cb3be7bd61.tar.gz
gentoo-2-ef1910f1f245d7034f9b5154fe0f37cb3be7bd61.tar.bz2
gentoo-2-ef1910f1f245d7034f9b5154fe0f37cb3be7bd61.zip
version bump - Thanks Brenden. bug #112758
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/ChangeLog7
-rw-r--r--app-admin/conky/Manifest12
-rw-r--r--app-admin/conky/conky-1.3.4.ebuild87
-rw-r--r--app-admin/conky/files/digest-conky-1.3.41
4 files changed, 96 insertions, 11 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
index e6453bf7d84d..190beb71d341 100644
--- a/app-admin/conky/ChangeLog
+++ b/app-admin/conky/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/conky
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.10 2005/10/18 11:57:09 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.11 2005/11/20 00:09:28 dragonheart Exp $
+
+*conky-1.3.4 (20 Nov 2005)
+
+ 20 Nov 2005; Daniel Black <dragonheart@gentoo.org> +conky-1.3.4.ebuild:
+ version bump - Thanks Brenden. bug #112758
*conky-1.3.3 (18 Oct 2005)
diff --git a/app-admin/conky/Manifest b/app-admin/conky/Manifest
index bd8013e20d6f..fd7ffcad5368 100644
--- a/app-admin/conky/Manifest
+++ b/app-admin/conky/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 aa02467310784f385d3c003f2029def5 ChangeLog 1833
MD5 199085e7a8ed12031f881663a3c100d1 conky-1.3.1.ebuild 2019
MD5 eb5f557defc5b1ed505b906498cdc395 conky-1.3.3.ebuild 1954
+MD5 0824c7d968d0c20ac96f1a335d812189 conky-1.3.4.ebuild 2344
MD5 31acfc146c31ba015fb9b8643deb2d57 files/digest-conky-1.3.1 64
MD5 6e51a33ec07b6f71db430f1839fd7902 files/digest-conky-1.3.3 64
+MD5 c5c1fb804afb4bd1255b602c8894a317 files/digest-conky-1.3.4 64
MD5 32bd4230c3ee12a8d5502d4bd57a9a3d metadata.xml 588
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2-ecc0.1.6 (GNU/Linux)
-
-iD8DBQFDVOMtmdTrptrqvGERAkCmAJ9eIjo4RyyrjBDhaa/TWyzzu15OaACfaqim
-WnXJW/wrUaXVGb3JwtxC/aM=
-=tCua
------END PGP SIGNATURE-----
diff --git a/app-admin/conky/conky-1.3.4.ebuild b/app-admin/conky/conky-1.3.4.ebuild
new file mode 100644
index 000000000000..b3a35595eb63
--- /dev/null
+++ b/app-admin/conky/conky-1.3.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.3.4.ebuild,v 1.1 2005/11/20 00:09:28 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
+HOMEPAGE="http://conky.sf.net"
+SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="truetype seti X ipv6"
+
+DEPEND_COMMON="
+ virtual/libc
+ X? (
+ virtual/x11
+ truetype? ( >=media-libs/freetype-2 )
+ )"
+
+RDEPEND="${DEPEND_COMMON}
+ seti? ( sci-astronomy/setiathome )"
+
+DEPEND="
+ ${DEPEND_COMMON}
+ >=sys-devel/automake-1.9
+ >=sys-devel/autoconf-2.59
+ sys-devel/libtool
+ sys-apps/grep
+ sys-apps/sed
+ sys-devel/gcc"
+
+
+src_compile() {
+ local mymake
+ if useq ipv6 ; then
+ ewarn
+ ewarn "You have the ipv6 USE flag enabled. Please note that"
+ ewarn "using the ipv6 USE flag with Conky disables the port"
+ ewarn "monitor."
+ ewarn
+ sleep 5
+ else
+ mymake="MPD_NO_IPV6=noipv6"
+ fi
+ local myconf
+ myconf="--enable-double-buffer --enable-own-window --enable-proc-uptime
+ --enable-mpd --enable-mldonkey"
+ econf \
+ ${myconf} \
+ $(use_enable truetype xft) \
+ $(use_enable X x11) \
+ $(use_enable !ipv6 portmon) \
+ $(use_enable seti) || die "econf failed"
+ emake ${mymake} || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "make install failed"
+ dodoc ChangeLog AUTHORS README doc/conkyrc.sample doc/variables.html
+ dodoc doc/docs.html doc/config_settings.html
+}
+
+pkg_postinst() {
+ einfo 'Default configuration file is "~/.conkyrc"'
+ einfo "you can find a sample configuration file in"
+ einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
+ einfo
+ einfo "For more info on Conky's new features,"
+ einfo "please look at the README and ChangeLog:"
+ einfo "/usr/share/doc/${PF}/README.gz"
+ einfo "/usr/share/doc/${PF}/ChangeLog.gz"
+ einfo "There are also pretty html docs available"
+ einfo "on Conky's site or in /usr/share/doc/${PF}"
+ einfo
+ einfo "Comment out temperature info lines if you have no kernel"
+ einfo "support for it."
+ einfo
+ einfo "Check out app-vim/conky-syntax for conkyrc"
+ einfo "syntax highlighting in Vim"
+ einfo
+ ewarn "Conky doesn't work with window managers that"
+ ewarn "take control over root window such as Gnome's nautilus."
+ ewarn
+}
diff --git a/app-admin/conky/files/digest-conky-1.3.4 b/app-admin/conky/files/digest-conky-1.3.4
new file mode 100644
index 000000000000..3d1c4064a29c
--- /dev/null
+++ b/app-admin/conky/files/digest-conky-1.3.4
@@ -0,0 +1 @@
+MD5 91f7d4ce29a6bc2d785f13224ea4aaac conky-1.3.4.tar.bz2 332871