summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-11-17 17:35:05 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-11-17 17:35:05 +0000
commitb9f100afdccba99fb57f6b588ca51e65000dd3fb (patch)
treee42af73d9680717c5d329434d9ec90e791be2abf /app-accessibility/sphinxbase
parentVersion bump, fixes a serious security issue, CVE-2011-4313 / bug 390753. (diff)
downloadgentoo-2-b9f100afdccba99fb57f6b588ca51e65000dd3fb.tar.gz
gentoo-2-b9f100afdccba99fb57f6b588ca51e65000dd3fb.tar.bz2
gentoo-2-b9f100afdccba99fb57f6b588ca51e65000dd3fb.zip
Initial commit.
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/sphinxbase')
-rw-r--r--app-accessibility/sphinxbase/ChangeLog10
-rw-r--r--app-accessibility/sphinxbase/metadata.xml5
-rw-r--r--app-accessibility/sphinxbase/sphinxbase-0.7.ebuild59
3 files changed, 74 insertions, 0 deletions
diff --git a/app-accessibility/sphinxbase/ChangeLog b/app-accessibility/sphinxbase/ChangeLog
new file mode 100644
index 000000000000..9f422183eeb1
--- /dev/null
+++ b/app-accessibility/sphinxbase/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-accessibility/sphinxbase
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/ChangeLog,v 1.1 2011/11/17 17:35:05 neurogeek Exp $
+
+*sphinxbase-0.7 (17 Nov 2011)
+
+ 17 Nov 2011; Jesus Rivero <neurogeek@gentoo.org> +sphinxbase-0.7.ebuild,
+ +metadata.xml:
+ Initial commit
+
diff --git a/app-accessibility/sphinxbase/metadata.xml b/app-accessibility/sphinxbase/metadata.xml
new file mode 100644
index 000000000000..72d214a2dedd
--- /dev/null
+++ b/app-accessibility/sphinxbase/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+</pkgmetadata>
diff --git a/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild b/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild
new file mode 100644
index 000000000000..5262b6dc5ebd
--- /dev/null
+++ b/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild,v 1.1 2011/11/17 17:35:05 neurogeek Exp $
+
+EAPI=3
+PYTHON_DEPEND="python? 2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit autotools-utils python
+
+DESCRIPTION="Support library required by the Sphinx Speech Recognition Engine"
+HOMEPAGE="http://cmusphinx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc lapack python static-libs"
+
+RDEPEND="lapack? ( virtual/lapack )"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.4.7 )"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_configure() {
+ econf \
+ $( use_with lapack ) \
+ $( use_with python ) \
+ $( use_enable static-libs static )
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources python
+
+ building() {
+ emake PYTHON="$(PYTHON)" PYTHON_INCLUDEDIR="$(python_get_includedir)" PYTHON_LIBDIR="$(python_get_libdir)"
+ }
+
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use python; then
+ python_execute_function -s --source-dir python -d
+ fi
+
+ if use doc; then
+ dohtml doc/html/*
+ fi
+
+ remove_libtool_files
+}