summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-10 09:41:05 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-10 09:41:05 +0000
commit9add7699c996b80c4be337b5707ae7a73e915401 (patch)
tree13b96b2596b190e0cd51201b1da6b4f82354738c
parentNLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen) and added dep... (diff)
downloadgentoo-2-9add7699c996b80c4be337b5707ae7a73e915401.tar.gz
gentoo-2-9add7699c996b80c4be337b5707ae7a73e915401.tar.bz2
gentoo-2-9add7699c996b80c4be337b5707ae7a73e915401.zip
NLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen) and gpm dependency fix from thomas.raschbacher@Netway.at (LordVan(Thomas Raschbacher))
-rw-r--r--gnome-extra/mc/ChangeLog17
-rw-r--r--gnome-extra/mc/files/digest-mc-4.5.55-r11
-rw-r--r--gnome-extra/mc/mc-4.5.55-r1.ebuild62
3 files changed, 71 insertions, 9 deletions
diff --git a/gnome-extra/mc/ChangeLog b/gnome-extra/mc/ChangeLog
index 115c3898b579..4ef112dae29f 100644
--- a/gnome-extra/mc/ChangeLog
+++ b/gnome-extra/mc/ChangeLog
@@ -1,13 +1,12 @@
# ChangeLog for gnome-extra/mc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/mc/ChangeLog,v 1.1 2002/02/01 21:53:29 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/mc/ChangeLog,v 1.2 2002/03/10 09:41:05 blocke Exp $
+
+*mc-4.5.55-r1 (10 Mar 2002)
+
+ 10 Mar 2002; Bruce A. Locke <blocke@shivan.org> mc-4.5.55-r1.ebuild :
+
+ - NLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen)
+ - gpm dependency fix from homas.raschbacher@Netway.at (LordVan(Thomas Raschbacher))
-*mc-4.5.55 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/gnome-extra/mc/files/digest-mc-4.5.55-r1 b/gnome-extra/mc/files/digest-mc-4.5.55-r1
new file mode 100644
index 000000000000..60b693823ea7
--- /dev/null
+++ b/gnome-extra/mc/files/digest-mc-4.5.55-r1
@@ -0,0 +1 @@
+MD5 bb670d48589f26f00b7fce8d25f66bd6 mc-4.5.55.tar.gz 4849958
diff --git a/gnome-extra/mc/mc-4.5.55-r1.ebuild b/gnome-extra/mc/mc-4.5.55-r1.ebuild
new file mode 100644
index 000000000000..a7c16ebe3c8e
--- /dev/null
+++ b/gnome-extra/mc/mc-4.5.55-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/mc/mc-4.5.55-r1.ebuild,v 1.1 2002/03/10 09:41:05 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME Midnight Commander"
+SRC_URI="http://www.gnome.org/projects/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/projects/mc/"
+
+DEPEND="virtual/glibc
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ pam? ( >=sys-libs/pam-0.72 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ >=sys-apps/e2fsprogs-1.19
+ >=dev-libs/glib-1.2.0
+ nls? ( sys-devel/gettext )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )"
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/vfs
+ cp smbfs.c smbfs.c.orig
+ sed -e "s:/etc/smb\.conf:/etc/smb/smb\.conf:" smbfs.c.orig > smbfs.c
+}
+
+src_compile() {
+ local myconf
+
+ use pam && myconf="${myconf} --with-pam"
+ use pam || myconf="${myconf} --without-pam"
+
+ use slang && myconf="${myconf} --with-slang"
+ use slang || myconf="${myconf} --with-included-slang"
+
+ use gnome && myconf="${myconf} --with-gnome"
+ use gnome || myconf="${myconf} --without-gnome"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ LDFLAGS="-lcrypt -lncurses" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-samba \
+ --with-vfs \
+ --with-netrc \
+ $myconf || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc ABOUT-NLS COPYING* FAQ INSTALL* NEWS README*
+}