summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2013-06-07 12:24:49 +0000
committerMikle Kolyada <zlogene@gentoo.org>2013-06-07 12:24:49 +0000
commit79829a1deb5fc1ae66d5911f69e8d4926aefb696 (patch)
treee1a77a96206297859ffe16d3dbb82ef54a4e3dcf
parentRemoving older versions (diff)
downloadgentoo-2-79829a1deb5fc1ae66d5911f69e8d4926aefb696.tar.gz
gentoo-2-79829a1deb5fc1ae66d5911f69e8d4926aefb696.tar.bz2
gentoo-2-79829a1deb5fc1ae66d5911f69e8d4926aefb696.zip
Respact AR wrt bug #469970 Drop old unstable packages.
(Portage version: 2.1.11.62/cvs/Linux i686, signed Manifest commit with key 0xC42EB5D6)
-rw-r--r--dev-perl/Net-DNS/ChangeLog9
-rw-r--r--dev-perl/Net-DNS/Net-DNS-0.660.0.ebuild12
-rw-r--r--dev-perl/Net-DNS/Net-DNS-0.680.0.ebuild38
-rw-r--r--dev-perl/Net-DNS/Net-DNS-0.700.0.ebuild42
-rw-r--r--dev-perl/Net-DNS/Net-DNS-0.710.0.ebuild42
-rw-r--r--dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild12
6 files changed, 25 insertions, 130 deletions
diff --git a/dev-perl/Net-DNS/ChangeLog b/dev-perl/Net-DNS/ChangeLog
index 9e5e624688e6..45b801bc94ca 100644
--- a/dev-perl/Net-DNS/ChangeLog
+++ b/dev-perl/Net-DNS/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Net-DNS
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/ChangeLog,v 1.167 2012/12/28 19:46:45 tove Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/ChangeLog,v 1.168 2013/06/07 12:24:49 zlogene Exp $
+
+ 07 Jun 2013; Mikle Kolyada <zlogene@gentoo.org> -Net-DNS-0.680.0.ebuild,
+ -Net-DNS-0.700.0.ebuild, -Net-DNS-0.710.0.ebuild, Net-DNS-0.660.0.ebuild,
+ Net-DNS-0.720.0.ebuild:
+ Respact AR wrt bug #469970 Drop old unstable packages.
*Net-DNS-0.720.0 (28 Dec 2012)
diff --git a/dev-perl/Net-DNS/Net-DNS-0.660.0.ebuild b/dev-perl/Net-DNS/Net-DNS-0.660.0.ebuild
index 128de4120ec4..ad4c6cd1c0a0 100644
--- a/dev-perl/Net-DNS/Net-DNS-0.660.0.ebuild
+++ b/dev-perl/Net-DNS/Net-DNS-0.660.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.660.0.ebuild,v 1.3 2011/12/20 09:00:54 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.660.0.ebuild,v 1.4 2013/06/07 12:24:49 zlogene Exp $
EAPI=4
MODULE_AUTHOR=OLAF
MODULE_VERSION=0.66
-inherit perl-module
+inherit toolchain-funcs perl-module
DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
@@ -39,3 +39,9 @@ src_prepare() {
fi
myconf="${myconf} --no-online-tests"
}
+
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+
+ perl-module_src_compile
+}
diff --git a/dev-perl/Net-DNS/Net-DNS-0.680.0.ebuild b/dev-perl/Net-DNS/Net-DNS-0.680.0.ebuild
deleted file mode 100644
index f03c8a5be528..000000000000
--- a/dev-perl/Net-DNS/Net-DNS-0.680.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.680.0.ebuild,v 1.2 2012/09/01 11:42:18 grobian Exp $
-
-EAPI=4
-
-MODULE_AUTHOR=OLAF
-MODULE_VERSION=0.68
-inherit perl-module
-
-DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="ipv6 test"
-
-RDEPEND="virtual/perl-Digest-MD5
- dev-perl/Digest-HMAC
- virtual/perl-Digest-SHA
- dev-perl/Net-IP
- ipv6? ( dev-perl/IO-Socket-INET6 )
- virtual/perl-MIME-Base64"
-DEPEND="${RDEPEND}
- test? (
- virtual/perl-Test-Simple
- dev-perl/Test-Pod
- )"
-
-PATCHES=( ${FILESDIR}/${PN}-0.68-ar.patch )
-SRC_TEST="do"
-
-src_prepare() {
- perl-module_src_prepare
- mydoc="TODO"
- # --IPv6-tests requires that you have external IPv6 connectivity
- # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
- myconf="${myconf} --no-online-tests --no-IPv6-tests"
-}
diff --git a/dev-perl/Net-DNS/Net-DNS-0.700.0.ebuild b/dev-perl/Net-DNS/Net-DNS-0.700.0.ebuild
deleted file mode 100644
index 7f2ae84b26ff..000000000000
--- a/dev-perl/Net-DNS/Net-DNS-0.700.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.700.0.ebuild,v 1.1 2012/12/08 11:10:56 tove Exp $
-
-EAPI=4
-
-MODULE_AUTHOR=NLNETLABS
-MODULE_VERSION=0.70
-inherit perl-module
-
-DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="ipv6 test"
-
-RDEPEND="
- virtual/perl-Digest-MD5
- dev-perl/Digest-HMAC
- virtual/perl-Digest-SHA
- dev-perl/Net-IP
- virtual/perl-MIME-Base64
- ipv6? (
- dev-perl/IO-Socket-INET6
- )
-"
-DEPEND="${RDEPEND}
- test? (
- virtual/perl-Test-Simple
- dev-perl/Test-Pod
- )"
-
-PATCHES=( ${FILESDIR}/${PN}-0.68-ar.patch )
-SRC_TEST="do"
-
-src_prepare() {
- perl-module_src_prepare
- mydoc="TODO"
- # --IPv6-tests requires that you have external IPv6 connectivity
- # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
- myconf="${myconf} --no-online-tests --no-IPv6-tests"
-}
diff --git a/dev-perl/Net-DNS/Net-DNS-0.710.0.ebuild b/dev-perl/Net-DNS/Net-DNS-0.710.0.ebuild
deleted file mode 100644
index c916df97a36d..000000000000
--- a/dev-perl/Net-DNS/Net-DNS-0.710.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.710.0.ebuild,v 1.1 2012/12/25 12:39:42 tove Exp $
-
-EAPI=4
-
-MODULE_AUTHOR=NLNETLABS
-MODULE_VERSION=0.71
-inherit perl-module
-
-DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="ipv6 test"
-
-RDEPEND="
- virtual/perl-Digest-MD5
- dev-perl/Digest-HMAC
- virtual/perl-Digest-SHA
- dev-perl/Net-IP
- virtual/perl-MIME-Base64
- ipv6? (
- dev-perl/IO-Socket-INET6
- )
-"
-DEPEND="${RDEPEND}
- test? (
- virtual/perl-Test-Simple
- dev-perl/Test-Pod
- )"
-
-PATCHES=( ${FILESDIR}/${PN}-0.68-ar.patch )
-SRC_TEST="do"
-
-src_prepare() {
- perl-module_src_prepare
- mydoc="TODO"
- # --IPv6-tests requires that you have external IPv6 connectivity
- # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
- myconf="${myconf} --no-online-tests --no-IPv6-tests"
-}
diff --git a/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild b/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild
index 7a0aba8b5d59..984bdedc486e 100644
--- a/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild
+++ b/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild,v 1.1 2012/12/28 19:46:45 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild,v 1.2 2013/06/07 12:24:49 zlogene Exp $
EAPI=5
MODULE_AUTHOR=NLNETLABS
MODULE_VERSION=0.72
-inherit perl-module
+inherit toolchain-funcs perl-module
DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
@@ -40,3 +40,9 @@ src_prepare() {
# as it connects to 2001:7b8:206:1:0:1234:be21:e31e
myconf="${myconf} --no-online-tests --no-IPv6-tests"
}
+
+src_compile() {
+ emake FULL_AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+
+ perl-module_src_compile
+}