summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-11-02 22:08:26 +0000
committerTim Harder <radhermit@gentoo.org>2014-11-02 22:08:26 +0000
commit670cddf7b7b1f4997df0938b725ab9bc62cff5e9 (patch)
tree0e952347e590bf39cf772afdc67c8d3a527c27ab
parentfix bug 527556 (diff)
downloadgentoo-2-670cddf7b7b1f4997df0938b725ab9bc62cff5e9.tar.gz
gentoo-2-670cddf7b7b1f4997df0938b725ab9bc62cff5e9.tar.bz2
gentoo-2-670cddf7b7b1f4997df0938b725ab9bc62cff5e9.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
-rw-r--r--app-vim/gentoo-syntax/ChangeLog8
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20141102.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/app-vim/gentoo-syntax/ChangeLog b/app-vim/gentoo-syntax/ChangeLog
index e4e2bc23d6cf..ce0c95d3839c 100644
--- a/app-vim/gentoo-syntax/ChangeLog
+++ b/app-vim/gentoo-syntax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/gentoo-syntax
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.159 2014/06/06 06:06:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.160 2014/11/02 22:08:26 radhermit Exp $
+
+*gentoo-syntax-20141102 (02 Nov 2014)
+
+ 02 Nov 2014; Tim Harder <radhermit@gentoo.org>
+ +gentoo-syntax-20141102.ebuild:
+ Version bump.
06 Jun 2014; Mike Frysinger <vapier@gentoo.org> gentoo-syntax-20130619.ebuild:
Add arm64 love.
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20141102.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20141102.ebuild
new file mode 100644
index 000000000000..48a31c647156
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20141102.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-20141102.ebuild,v 1.1 2014/11/02 22:08:26 radhermit Exp $
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and portage related syntax highlighting, filetype, and indent settings"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ elog "Note for developers and anyone else who edits ebuilds:"
+ elog " This release of gentoo-syntax now contains filetype rules to set"
+ elog " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ elog " If you find this feature breaks things, please submit a bug and"
+ elog " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ elog " flag to remove these rules."
+ fi
+ fi
+}