summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-10-14 20:57:01 +0000
committerPacho Ramos <pacho@gentoo.org>2013-10-14 20:57:01 +0000
commit66e5de33eb6a87c408d30da9d9d186d9fe19493c (patch)
treec918d5152bed52d54c33bb5a447e238fea6032b3
parentSwitch to git-r3. (diff)
downloadgentoo-2-66e5de33eb6a87c408d30da9d9d186d9fe19493c.tar.gz
gentoo-2-66e5de33eb6a87c408d30da9d9d186d9fe19493c.tar.bz2
gentoo-2-66e5de33eb6a87c408d30da9d9d186d9fe19493c.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--app-office/abiword/ChangeLog10
-rw-r--r--app-office/abiword/abiword-3.0.0.ebuild141
-rw-r--r--app-office/abiword/files/abiword-3.0.0-eds-3.6.patch11
-rw-r--r--app-office/abiword/metadata.xml23
4 files changed, 171 insertions, 14 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index e3a763e1e694..37b5f5dfacca 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/abiword
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.262 2012/08/05 21:44:50 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.263 2013/10/14 20:57:01 pacho Exp $
+
+*abiword-3.0.0 (14 Oct 2013)
+
+ 14 Oct 2013; Pacho Ramos <pacho@gentoo.org> +abiword-3.0.0.ebuild,
+ +files/abiword-3.0.0-eds-3.6.patch, metadata.xml:
+ Version bump
05 Aug 2012; Anthony G. Basile <blueness@gentoo.org> abiword-2.8.6-r2.ebuild:
Keyword ~arm
diff --git a/app-office/abiword/abiword-3.0.0.ebuild b/app-office/abiword/abiword-3.0.0.ebuild
new file mode 100644
index 000000000000..6c9ae7440ea5
--- /dev/null
+++ b/app-office/abiword/abiword-3.0.0.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-3.0.0.ebuild,v 1.1 2013/10/14 20:57:01 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="calendar collab cups eds gnome grammar +introspection latex map math ots openxml +plugins readline redland spell wordperfect wmf thesaurus"
+
+# You need 'plugins' enabled if want to enable the extra plugins
+REQUIRED_USE="!plugins? ( !collab !grammar !latex !math !openxml !ots !readline !thesaurus !wordperfect !wmf )"
+
+RDEPEND="
+ >=app-text/wv-1.2
+ dev-lang/perl
+ >=dev-libs/boost-1.40.0
+ >=dev-libs/fribidi-0.10.4
+ >=dev-libs/glib-2.16:2
+ >=dev-libs/libgcrypt-1.4.5
+ >=gnome-base/librsvg-2.16:2
+ >=gnome-extra/libgsf-1.14.18
+ >=media-libs/libpng-1.2
+ virtual/jpeg
+ >=x11-libs/cairo-1.10[X]
+ >=x11-libs/gtk+-3.0.8:3[cups?]
+ calendar? ( >=dev-libs/libical-0.46 )
+ eds? ( gnome-extra/evolution-data-server )
+ gnome? ( >=x11-libs/goffice-0.10.0:0.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.0.0 )
+ map? ( >=media-libs/libchamplain-0.12 )
+ plugins? (
+ collab? (
+ >=dev-libs/libxml2-2.4
+ >=net-libs/loudmouth-1
+ net-libs/libsoup:2.4
+ net-libs/gnutls )
+ grammar? ( >=dev-libs/link-grammar-4.2.1 )
+ latex? ( dev-libs/libxslt )
+ math? ( >=x11-libs/gtkmathview-0.7.5 )
+ ots? ( >=app-text/ots-0.5 )
+ readline? ( sys-libs/readline )
+ thesaurus? ( >=app-text/aiksaurus-1.2[gtk] )
+ wordperfect? (
+ app-text/libwpd:0.9
+ app-text/libwpg:0.2 )
+ wmf? ( >=media-libs/libwmf-0.2.8 )
+ )
+ redland? (
+ >=dev-libs/redland-1.0.10
+ >=dev-libs/rasqal-0.9.17 )
+ spell? ( >=app-text/enchant-1.2 )
+ !<app-office/abiword-plugins-2.8
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ collab? ( dev-cpp/asio )
+"
+
+src_prepare() {
+ # readme.txt will be installed using dodoc
+ sed '/readme\.txt\|abw/d' \
+ -i user/wp/Makefile.am user/wp/Makefile.in || die
+
+ # http://bugzilla.abisource.com/show_bug.cgi?id=13532
+ epatch "${FILESDIR}/${PN}-3.0.0-eds-3.6.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local plugins=""
+
+ if use plugins; then
+ # Plugins depending on libgsf
+ plugins="t602 docbook clarisworks wml kword hancom openwriter pdf
+ loadbindings mswrite garble pdb applix opendocument sdw xslfo"
+
+ # Plugins depending on librsvg
+ # But doesn't build: http://bugzilla.abisource.com/show_bug.cgi?id=13563
+ #plugins="${plugins} svg"
+
+ # Plugins not depending on anything
+ plugins="${plugins} gimp bmp freetranslation iscii s5 babelfish opml eml
+ wikipedia gdict passepartout google presentation urldict hrtext mif"
+
+ # inter7eps: eps.h
+ # libtidy: gsf + tidy.h
+ # paint: windows only ?
+ use collab && plugins="${plugins} collab"
+ use gnome && plugins="${plugins} goffice"
+ use latex && plugins="${plugins} latex"
+ use math && plugins="${plugins} mathview"
+ use openxml && plugins="${plugins} openxml"
+ use ots && plugins="${plugins} ots"
+ # psion: >=psiconv-0.9.4
+ use readline && plugins="${plugins} command"
+ use thesaurus && plugins="${plugins} aiksaurus"
+ use wmf && plugins="${plugins} wmf"
+ # wordperfect: >=wpd-0.9 >=wpg-0.2
+ use wordperfect && plugins="${plugins} wpg"
+ fi
+
+ gnome2_src_configure \
+ --enable-plugins="$(echo ${plugins})" \
+ --disable-static \
+ --disable-default-plugins \
+ --disable-builtin-plugins \
+ --disable-collab-backend-telepathy \
+ --enable-clipart \
+ --enable-statusbar \
+ --enable-templates \
+ --with-gio \
+ --without-gnomevfs \
+ --without-gtk2 \
+ $(use_with gnome goffice) \
+ $(use_with calendar libical) \
+ $(use_enable cups print) \
+ $(use_enable collab collab-backend-xmpp) \
+ $(use_enable collab collab-backend-tcp) \
+ $(use_enable collab collab-backend-service) \
+ $(use_with eds evolution-data-server) \
+ $(use_enable introspection) \
+ $(use_with map champlain) \
+ $(use_with redland) \
+ $(use_enable spell)
+}
+
+src_install() {
+ gnome2_src_install
+ dodoc user/wp/readme.txt
+}
diff --git a/app-office/abiword/files/abiword-3.0.0-eds-3.6.patch b/app-office/abiword/files/abiword-3.0.0-eds-3.6.patch
new file mode 100644
index 000000000000..b7e362e76604
--- /dev/null
+++ b/app-office/abiword/files/abiword-3.0.0-eds-3.6.patch
@@ -0,0 +1,11 @@
+--- src/text/ptbl/xp/pd_DocumentRDF.cpp.orig 2012-07-26 02:59:34.000000000 +0000
++++ src/text/ptbl/xp/pd_DocumentRDF.cpp 2012-07-26 02:59:50.000000000 +0000
+@@ -1884,7 +1884,7 @@
+
+ #ifdef WITH_EVOLUTION_DATA_SERVER
+ extern "C" {
+- #include <libebook/e-book.h>
++ #include <libebook/libebook.h>
+ };
+
+ static std::string get( EVCard* c, const char* v )
diff --git a/app-office/abiword/metadata.xml b/app-office/abiword/metadata.xml
index 03f0799c5d78..c87852d74d5d 100644
--- a/app-office/abiword/metadata.xml
+++ b/app-office/abiword/metadata.xml
@@ -3,17 +3,16 @@
<pkgmetadata>
<herd>gnome-office</herd>
<use>
- <flag name='collab'>Enable collaborative editing plugin</flag>
- <flag name='grammar'>Enable grammar checking via
- <pkg>dev-libs/link-grammar</pkg></flag>
- <flag name='math'>Enable support for <pkg>x11-libs/gtkmathview</pkg></flag>
- <flag name='openxml'>Enable OpenXML support</flag>
- <flag name='ots'>Enable Text Summarizer plugin</flag>
- <flag name='plugins'>Enable plugins build (see
- http://www.abisource.com/wiki/PluginMatrix for more information). If your
- file cannot be opened due lack of support, try enabling this.</flag>
- <flag name='thesaurus'>Enable thesaurus support</flag>
- <flag name='wordperfect'>Enable wordperfect file support via
- <pkg>app-text/libwpd</pkg></flag>
+ <flag name='collab'>Enable collaborative editing plugin</flag>
+ <flag name='grammar'>Enable grammar checking via <pkg>dev-libs/link-grammar</pkg></flag>
+ <flag name="map">Enable world map support through <pkg>media-libs/libchamplain</pkg></flag>
+ <flag name='math'>Enable support for <pkg>x11-libs/gtkmathview</pkg></flag>
+ <flag name='openxml'>Enable OpenXML support</flag>
+ <flag name='ots'>Enable Text Summarizer plugin</flag>
+ <flag name='plugins'>Enable plugins build (see http://www.abisource.com/wiki/PluginMatrix for more information). If your
+ file cannot be opened due lack of support, try enabling this.</flag>
+ <flag name="redland">Enables support redland and raptor libs.</flag>
+ <flag name='thesaurus'>Enable thesaurus support</flag>
+ <flag name='wordperfect'>Enable wordperfect file support via <pkg>app-text/libwpd</pkg></flag>
</use>
</pkgmetadata>