summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-14 10:09:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-14 10:09:48 +0000
commit3b64f565d4a8675b66d31b2ba4d8d593e05eaf3a (patch)
tree8f685c414ca82d7822149f3a2afc80171fa82378
parentStable for AMD64, wrt bug #398815 (diff)
downloadgentoo-2-3b64f565d4a8675b66d31b2ba4d8d593e05eaf3a.tar.gz
gentoo-2-3b64f565d4a8675b66d31b2ba4d8d593e05eaf3a.tar.bz2
gentoo-2-3b64f565d4a8675b66d31b2ba4d8d593e05eaf3a.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
-rw-r--r--x11-misc/efax-gtk/ChangeLog9
-rw-r--r--x11-misc/efax-gtk/efax-gtk-3.2.9.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/x11-misc/efax-gtk/ChangeLog b/x11-misc/efax-gtk/ChangeLog
index c5e7bd1cbb33..6ec5b69b1f52 100644
--- a/x11-misc/efax-gtk/ChangeLog
+++ b/x11-misc/efax-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/efax-gtk
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/efax-gtk/ChangeLog,v 1.32 2011/03/02 16:27:46 signals Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/efax-gtk/ChangeLog,v 1.33 2012/01/14 10:09:48 ssuominen Exp $
+
+*efax-gtk-3.2.9 (14 Jan 2012)
+
+ 14 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +efax-gtk-3.2.9.ebuild:
+ Version bump.
02 Mar 2011; Kevin McCarthy <signals@gentoo.org> efax-gtk-3.0.18.ebuild,
efax-gtk-3.2.2.ebuild:
diff --git a/x11-misc/efax-gtk/efax-gtk-3.2.9.ebuild b/x11-misc/efax-gtk/efax-gtk-3.2.9.ebuild
new file mode 100644
index 000000000000..8a7b65d1e87f
--- /dev/null
+++ b/x11-misc/efax-gtk/efax-gtk-3.2.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/efax-gtk/efax-gtk-3.2.9.ebuild,v 1.1 2012/01/14 10:09:48 ssuominen Exp $
+
+EAPI=4
+
+DESCRIPTION="A graphical frontend for the 'efax' application"
+HOMEPAGE="http://efax-gtk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.tgz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.10
+ media-libs/tiff:0
+ x11-libs/libX11
+ x11-libs/c++-gtk-utils:3
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS="AUTHORS BUGS ChangeLog README"
+
+src_prepare() {
+ # Prevent sandbox violation with chown/chgrp and existing spooldir
+ sed -i -e '/ch.*lp.*spooldir/d' efax-gtk-faxfilter/Makefile.in || die
+
+ sed -i \
+ -e '/^Encoding/d' \
+ -e '/^Icon/s:.png::' \
+ -e '/^Categories/s:Application;::' \
+ ${PN}.desktop || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --with-gtk-version=gtk3
+}
+
+pkg_postinst() {
+ local spooldir="${EROOT}"/var/spool/fax
+ [[ -d ${spooldir} ]] && chown lp:lp "${spooldir}"
+}