summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-11 08:38:31 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-11 08:38:31 +0000
commit09b90782eac8ee9143599b5647ae90bd26026a5f (patch)
treea1d6103a20680b8077c3e2cdbe8bfaaaa04f0175
parentVersion bumps for security bug 430718. (diff)
downloadgentoo-2-09b90782eac8ee9143599b5647ae90bd26026a5f.tar.gz
gentoo-2-09b90782eac8ee9143599b5647ae90bd26026a5f.tar.bz2
gentoo-2-09b90782eac8ee9143599b5647ae90bd26026a5f.zip
Version bumps for security bug 430718.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
-rw-r--r--dev-ruby/railties/ChangeLog9
-rw-r--r--dev-ruby/railties/railties-3.0.17.ebuild47
-rw-r--r--dev-ruby/railties/railties-3.1.8.ebuild54
3 files changed, 109 insertions, 1 deletions
diff --git a/dev-ruby/railties/ChangeLog b/dev-ruby/railties/ChangeLog
index 2dc327c12089..621d8eda72f5 100644
--- a/dev-ruby/railties/ChangeLog
+++ b/dev-ruby/railties/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/railties
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.34 2012/08/10 06:45:19 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.35 2012/08/11 08:38:31 graaff Exp $
+
+*railties-3.1.8 (11 Aug 2012)
+*railties-3.0.17 (11 Aug 2012)
+
+ 11 Aug 2012; Hans de Graaff <graaff@gentoo.org> +railties-3.0.17.ebuild,
+ +railties-3.1.8.ebuild:
+ Version bumps for security bug 430718.
*railties-3.2.8 (10 Aug 2012)
diff --git a/dev-ruby/railties/railties-3.0.17.ebuild b/dev-ruby/railties/railties-3.0.17.ebuild
new file mode 100644
index 000000000000..82098cf8b8be
--- /dev/null
+++ b/dev-ruby/railties/railties-3.0.17.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/railties-3.0.17.ebuild,v 1.1 2012/08/11 08:38:31 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test:regular"
+RUBY_FAKEGEM_TASK_DOC="generate_guides"
+RUBY_FAKEGEM_DOCDIR="guides/output"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="railties.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools for creating, working with, and running Rails applications."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/railties"
+
+# The test suite has many failures, most likely due to a mismatch in
+# exact dependencies or environment specifics. Needs further
+# investigation.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/rdoc-3.4
+ >=dev-ruby/thor-0.14.4
+ >=dev-ruby/rake-0.8.7"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )
+ doc? (
+ >=dev-ruby/redcloth-4.1.1
+ )"
diff --git a/dev-ruby/railties/railties-3.1.8.ebuild b/dev-ruby/railties/railties-3.1.8.ebuild
new file mode 100644
index 000000000000..52e18e8d4387
--- /dev/null
+++ b/dev-ruby/railties/railties-3.1.8.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/railties-3.1.8.ebuild,v 1.1 2012/08/11 08:38:31 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test:regular"
+RUBY_FAKEGEM_TASK_DOC="generate_guides"
+RUBY_FAKEGEM_DOCDIR="guides/output"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="railties.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools for creating, working with, and running Rails applications."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/railties"
+
+# The test suite has many failures, most likely due to a mismatch in
+# exact dependencies or environment specifics. Needs further
+# investigation.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/rdoc-3.4
+ >=dev-ruby/thor-0.14.6
+ >=dev-ruby/rack-ssl-1.3.2:1.3
+ >=dev-ruby/rake-0.8.7"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )
+ doc? (
+ >=dev-ruby/redcloth-4.1.1
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\)/d' ../Gemfile || die
+}