summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-08-03 17:01:55 +0000
committerJeroen Roovers <jer@gentoo.org>2013-08-03 17:01:55 +0000
commit08ce881e5eff96bf07e61da26e4a549f51454ac9 (patch)
tree22e898d5f0c80dea137553738fcd465e873ffea9
parentFix 0.8.2-sys_leveldb.patch (diff)
downloadgentoo-2-08ce881e5eff96bf07e61da26e4a549f51454ac9.tar.gz
gentoo-2-08ce881e5eff96bf07e61da26e4a549f51454ac9.tar.bz2
gentoo-2-08ce881e5eff96bf07e61da26e4a549f51454ac9.zip
Simplify Makefile. Add some includes, treat realloc the same as malloc.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key A792A613)
-rw-r--r--x11-misc/xwit/ChangeLog10
-rw-r--r--x11-misc/xwit/files/Makefile6
-rw-r--r--x11-misc/xwit/files/xwit-3.4-malloc-includes.patch49
-rw-r--r--x11-misc/xwit/xwit-3.4-r1.ebuild32
4 files changed, 90 insertions, 7 deletions
diff --git a/x11-misc/xwit/ChangeLog b/x11-misc/xwit/ChangeLog
index 79781155689a..100ea9847fae 100644
--- a/x11-misc/xwit/ChangeLog
+++ b/x11-misc/xwit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xwit
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xwit/ChangeLog,v 1.11 2012/12/23 20:30:14 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xwit/ChangeLog,v 1.12 2013/08/03 17:01:55 jer Exp $
+
+*xwit-3.4-r1 (03 Aug 2013)
+
+ 03 Aug 2013; Jeroen Roovers <jer@gentoo.org> +xwit-3.4-r1.ebuild,
+ +files/xwit-3.4-malloc-includes.patch, files/Makefile:
+ Simplify Makefile. Add some includes, treat realloc the same as malloc.
23 Dec 2012; Ulrich Müller <ulm@gentoo.org> xwit-3.4.ebuild:
Fix LICENSE, see README and notices in source files, bug 446764.
diff --git a/x11-misc/xwit/files/Makefile b/x11-misc/xwit/files/Makefile
index d16ec11641a6..7b106f0d7168 100644
--- a/x11-misc/xwit/files/Makefile
+++ b/x11-misc/xwit/files/Makefile
@@ -1,10 +1,6 @@
src = xwit.c dsimple.c ClientWin.c
-o = $(addsuffix .o,$(basename ${src}))
all: xwit
-%.o: %.cpp
- $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
-
xwit: $(o)
- $(CC) $(LDFLAGS) $(o) -o xwit -lX11
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(src) -o xwit -lX11
diff --git a/x11-misc/xwit/files/xwit-3.4-malloc-includes.patch b/x11-misc/xwit/files/xwit-3.4-malloc-includes.patch
new file mode 100644
index 000000000000..beda933c19f3
--- /dev/null
+++ b/x11-misc/xwit/files/xwit-3.4-malloc-includes.patch
@@ -0,0 +1,49 @@
+--- a/dsimple.c 1995-10-19 00:59:17.000000000 +0100
++++ b/dsimple.c 2013-08-03 18:27:16.670506562 +0200
+@@ -5,6 +5,8 @@
+ #include <X11/Xutil.h>
+ #include <X11/cursorfont.h>
+ #include <stdio.h>
++#include <stdlib.h> /* malloc() */
++#include <unistd.h> /* exit() */
+ /*
+ * Other_stuff.h: Definitions of routines in other_stuff.
+ *
+@@ -46,7 +48,7 @@
+ char *Malloc(size)
+ unsigned size;
+ {
+- char *data, *malloc();
++ char *data; /*, *malloc(); */
+
+ if (!(data = malloc(size)))
+ Fatal_Error("Out of memory!");
+@@ -62,7 +64,7 @@
+ char *ptr;
+ int size;
+ {
+- char *new_ptr, *realloc();
++ char *new_ptr; /*, *realloc(); */
+
+ if (!ptr)
+ return(Malloc(size));
+--- a/xwit.c 1997-10-21 03:32:54.000000000 +0200
++++ b/xwit.c 2013-08-03 18:38:52.075456902 +0200
+@@ -31,6 +31,8 @@
+ #include <X11/Xutil.h>
+ #include <X11/Xproto.h>
+ #include <stdio.h>
++#include <stdlib.h> /* atoi() */
++#include <sys/select.h> /* select() */
+ #include <sys/time.h>
+ #include "dsimple.h"
+
+@@ -134,7 +136,7 @@
+ struct timeval tv;
+ tv.tv_sec = ms/1000;
+ tv.tv_usec = (ms%1000)*1000;
+- select(0,(int*)0,(int*)0,(int*)0,&tv);
++ select(0,0,0,0,&tv);
+ }
+
+ /*
diff --git a/x11-misc/xwit/xwit-3.4-r1.ebuild b/x11-misc/xwit/xwit-3.4-r1.ebuild
new file mode 100644
index 000000000000..9ef42265d0cc
--- /dev/null
+++ b/x11-misc/xwit/xwit-3.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xwit/xwit-3.4-r1.ebuild,v 1.1 2013/08/03 17:01:55 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A collection of simple routines to call some of those X11 functions"
+HOMEPAGE="http://ftp.x.org/contrib/utilities/xwit-3.4.README"
+SRC_URI="http://ftp.x.org/contrib/utilities/${P}.tar.gz"
+
+LICENSE="public-domain HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-malloc-includes.patch
+
+ cp -vf "${FILESDIR}"/Makefile .
+
+ tc-export CC
+}
+
+src_install() {
+ dobin xwit
+ newman xwit.man xwit.1
+}